欢迎光临
我们一直在努力

Linux升级Mysql后报错conflicts with file怎么办?

  mysql服务器提示升级,不少Linux用户在升级完mysql发现总是提示conflicts with file from package,刚开始还不在意,后来直接不能启动mysql服务器了,首要的任务是明白该错误提示表达的是什么,再找解决方法。

Linux升级Mysql后报错conflicts with file怎么办?

  首先发现不兼容包,所以要移除冲突的libs包,然后再去安装!

  代码如下

  rpm -e –nodeps mysql-5.0.95-5.el5_9.x86_64

  或者使用

  yum -y remove mysql-libs-5.0.95*

  然后我们安装mysql5.1就好了

  rpm -ivh mysql-5.1.58-jason.1.i386.rpm

  不推荐安装mysql5.5,第一队程序的兼容不是很好,队centos的兼容也不是很好!

  前面有一个VPS在测试的时候就会出现了程序的不兼容!webmin配置好就是利器,配置不好就是垃圾!

  如果在配置中数据库无法启动或者是错误的话可以到下面这篇文章看看:

  解决办法1:

  使用sql语句插入mysql.servers表

  解决不可以创建数据库/用户等问题。

  webmin备份数据库的时会有错误提示,但仍然会生成sql文件。

  可以在SSH上面修改没mysql:

  解决方法2:

  ssh文本操作方法

  mysql_upgrade -u root -p “MYSQL-ROOT的密码”

  如:

  mysql_upgrade -uroot -p 123456

  彻底解决!!

  上面就是Linux升级mysql后报错conflicts with file from package的解决方法了,本文提供了两种解决方法,以免第一种方法无效。

赞(0)
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权
文章名称:《Linux升级Mysql后报错conflicts with file怎么办?》
文章链接:https://pc.adminn.cn/2312.html
本站属非盈利性网站,不接受任何形式广告。本站提供文章纯教程分享,给网民提供教程,文章均采集网路,如侵犯您的权益,请联系我们删除,QQ:805750011。