欢迎光临
我们一直在努力

CentOS 6.2升级yum时提示libotf.so.0错误怎么办?

  CentOS下很多软件的安装需要通过yum来完成,可是CentOS6.2在升级yum的时候报错,提示libotf.so.0,很多人遇到这种情况就不知如何处理了,下面小编就给大家介绍下CentOS 6.2 yum update提示libotf.so.0的解决方法。

 CentOS 6.2升级yum时提示libotf.so.0错误怎么办?

  报错如下:

  Setting up Update Process

  Resolving Dependencies

  –》 Running transaction check

  —》 Package openmpi.x86_64 0:1.5.3-3.el6 will be updated

  –》 Processing Dependency: libotf.so.0()(64bit) for package: 1:emacs-23.1-21.el6_2.3.x86_64

  Package openmpi-psm is obsoleted by openmpi, but obsoleting package does not provide for requirements

  —》 Package openmpi.x86_64 0:1.5.4-1.el6 will be an update

  –》 Finished Dependency Resolution

  Error: Package: 1:emacs-23.1-21.el6_2.3.x86_64 (@updates)

  Requires: libotf.so.0()(64bit)

  Removing: openmpi-1.5.3-3.el6.x86_64 (@anaconda-CentOS-201112091719.x86_64/6.2)

  libotf.so.0()(64bit)

  Updated By: openmpi-1.5.4-1.el6.x86_64 (base)

  Not found

  Available: libotf-0.9.9-3.1.el6.x86_64 (base)

  libotf.so.0()(64bit)

  Available: openmpi-psm-1.5.3-3.el6.x86_64 (base)

  libotf.so.0()(64bit)

  You could try using –skip-broken to work around the problem

  You could try running: rpm -Va –nofiles –nodigest

  事实上是openmpi的错误,解决办法:

  yum install libotf

  上面就是CentOS 6.2升级yum报错libotf.so.0的解决方法,你是否遇到了相同的yum update问题呢?不妨试试本文介绍的方法解决吧。

赞(0)
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权
文章名称:《CentOS 6.2升级yum时提示libotf.so.0错误怎么办?》
文章链接:https://pc.adminn.cn/3043.html
本站属非盈利性网站,不接受任何形式广告。本站提供文章纯教程分享,给网民提供教程,文章均采集网路,如侵犯您的权益,请联系我们删除,QQ:805750011。