欢迎光临
我们一直在努力

Ubuntu安装Pacman包管理器的步骤

  Ubuntu系统操作中,Pacman是一款软件包管理器,能够对官方的Arch库和自己创建的软件包进行管理,但是有时在安装Pacman的时候会出错,下面小编就给大家介绍下Ubuntu如何安装Pacman。

 Ubuntu安装Pacman包管理器的步骤

  1,wget ‘ftp://ftp.archlinux.org/other/pacman/pacman-4.1.2.tar.gz’下载软件包

  2,tar xvf pacman-4.1.2.tar.gz,解压缩软件

  3,cd pacman-4.1.2/,进入代码,执行。/configure,提示没有libarchive

  4,执行sudo apt-get libarchive-dev安装libarchive

  5,再次执行。/configure,通过

  6,执行make,出错

  ——————————————————————————-

  CC libalpm_la-be_sync.lo

  be_sync.c: In function ‘_alpm_validate_filename’:

  be_sync.c:499: error: ‘PATH_MAX’ undeclared (first use in this function)

  be_sync.c:499: error: (Each undeclared identifier is reported only once

  be_sync.c:499: error: for each function it appears in.)

  make[3]: *** [libalpm_la-be_sync.lo] 错误 1

  make[2]: *** [all-recursive] 错误 1

  make[1]: *** [all-recursive] 错误 1

  make: *** [all] 错误 2

  ——————————————————————————–

  7,gedit lib/libalpm/be_sync.c,代码文件,找到代码

  ——————————————————————————-

  static int _alpm_validate_filename(alpm_db_t *db, const char *pkgname,

  const char *filename)

  {

  size_t len = strlen(filename);

  if(filename[0] == ‘。’) {

  errno = EINVAL;

  _alpm_log(db-》handle, ALPM_LOG_ERROR, _(“%s database is inconsistent: filename ”

  “of package %s is illegal\n”), db-》treename, pkgname);

  return -1;

  } else if(memchr(filename, ‘/’, len) != NULL) {

  errno = EINVAL;

  _alpm_log(db-》handle, ALPM_LOG_ERROR, _(“%s database is inconsistent: filename ”

  “of package %s is illegal\n”), db-》treename, pkgname);

  return -1;

  }

  else if(len 》 PATH_MAX) {

  errno = EINVAL;

  _alpm_log(db-》handle, ALPM_LOG_ERROR, _(“%s database is inconsistent: filename ”

  “of package %s is too long\n”), db-》treename, pkgname);

  return -1;

  }

  return 0;

  }

  ——————————————————————————-

  修改如下

  ——————————————————————————-

  static int _alpm_validate_filename(alpm_db_t *db, const char *pkgname,

  const char *filename)

  {

  size_t len = strlen(filename);

  if(filename[0] == ‘。’) {

  errno = EINVAL;

  _alpm_log(db-》handle, ALPM_LOG_ERROR, _(“%s database is inconsistent: filename ”

  “of package %s is illegal\n”), db-》treename, pkgname);

  return -1;

  } else if(memchr(filename, ‘/’, len) != NULL) {

  errno = EINVAL;

  _alpm_log(db-》handle, ALPM_LOG_ERROR, _(“%s database is inconsistent: filename ”

  “of package %s is illegal\n”), db-》treename, pkgname);

  return -1;

  }

  /*

  else if(len 》 PATH_MAX) {

  errno = EINVAL;

  _alpm_log(db-》handle, ALPM_LOG_ERROR, _(“%s database is inconsistent: filename ”

  “of package %s is too long\n”), db-》treename, pkgname);

  return -1;

  }

  */

  return 0;

  }

  ——————————————————————————-

  保存,退出

  8,执行make&& make install,等待安装完成。

  上面就是Ubuntu安装Pacman的方法介绍了,通常安装的时候会在执行make出错,出错后按照本文介绍的代码进行安装,最后再执行make&& make install完成安装。

赞(0)
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权
文章名称:《Ubuntu安装Pacman包管理器的步骤》
文章链接:https://pc.adminn.cn/3669.html
本站属非盈利性网站,不接受任何形式广告。本站提供文章纯教程分享,给网民提供教程,文章均采集网路,如侵犯您的权益,请联系我们删除,QQ:805750011。